June 10, 2010
Filed Under (Linux, Ubuntu) by Ollie Cronk on 10-06-2010

Yeah finally fixed an annoying issue with my Linux Server at home (nice to flex my Linux admin skills!) documenting it here in case I ever need the commands again or its useful to others:

Problem:

Ubuntu 9.04 no longer booted after a minor update (from .15 to .16) with my Software RAID setup as described in these reported bugs:

https://bugs.launchpad.net/ubuntu/+source/mdadm/+bug/330298

https://bugs.launchpad.net/ubuntu/+source/mdadm/+bug/158918

Fix:

Following the instructions on https://bugs.launchpad.net/ubuntu/+source/mdadm/+bug/136252/comments/5 fixed the problem but you need to run update-initfs -u so it updates.

Amazing what you learn when having to fix this kind of stuff – for one I now understand the memory based file system that linux uses during boot better.



July 24, 2009
Filed Under (Life, Mountain Biking) by Ollie Cronk on 24-07-2009

Some Recent Tech Discoveries I thought I’d share:

The Good:

Windows 7 RC – writing the blog post from it – excellent OS (and that says a lot coming from me!)

Ubuntu 9.04 -What can I say – wow – is the OS market hotting up or what? Right when they said the Browser will be the O/S – we’ll we aren’t there yet (well not until Google’s Chrome OS anyway…)

Spotify – sure lots of people know about this one now but great streaming music service. Kind of like a commercial radio station where you get to choose the playlist. But native version for Linux would be nice (netbooks will make this kind of porting happen organically now I suspect??)

Bitly – specifically the Bit.ly Sidebar for your browser – very clever. You’ll notice I’m starting to use more bit.ly links in my blog posts but for Twitter they are essential.

The Bad:

ebox – Not a good move to just try and install this on a Ubuntu box (tried this at home) screwed lots of stuff up. Nice idea but if you want to try it out use a seperate box. It looks good and the concept is a great idea but I think its a bit too flawed for me right now (sorry ebox devs).

Denyhosts (prevents brute force attacks on SSH by adding IP addresses that repeatedly fail to login to a black list – in /etc/hosts.deny)  silently stopped working some time ago on my Ubuntu server (due to an upgrade of Python by the looks of things). Following the fix on this forum thread sorted the problem although I found the file you need to change is:  /usr/share/denyhosts/daemon-control-dist rather than the one mentioned.

The Ugly:

HMG Info Sec standards (or rather the OTT implementation of) – I probably can’t say any more or I’ll get burned in acid (its a long and painful story…!)

More posts to come. Enjoy the summer everyone. I intend to on a ride around Litchfield tomorrow – embedded Google Map to follow no doubt…!




April 27, 2009
Filed Under (Linux, Open Source, Ubuntu) by Ollie Cronk on 27-04-2009

Screenshot of VirtualBox running XP under Ubuntu
Recently I’ve started using Virtualisation – for those who don’t know this is running an Operating System or OS for short (such as Windows) as an application (so you could think of it as running a computer within a computer). I’ve started doing this as I’ve got frustrated with Windows slowing down after being installed for a few months. This way I can run Linux which is very stable and performs consistantly as the main Operating System (or the “Host”) and then run various “Guest” OS installations – such as Windows. You can take snapshots or save the state of the Guest machines – which is ideal if you want to go back to how your Windows install used to be (but unlike reinstalling all your applications and settings are as they were).

Generally Windows runs at the same speed as it does normally – so long as you don’t run too much stuff on the Host OS at the same time – but of course there are limitation – eg Games or software that needs access to devices that can’t be provided via VirtualBox. And of course you could run the reverse setup – if you fancy trying Linux as a Guest OS but keeping the safety net of Windows as your main Operating System.

Anyway I’m posting this as I’ve been using VirtualBox on Ubuntu Linux to run Windows XP. On a recent upgrade from Ubuntu 8.10 to the latest version 9.04 VirtualBox failed to run. This was fixed by running the command given in the error message (its nice to get a very useful error message in software!)

The command I had to run was sudo /etc/init.d/vboxdrv setup

Once VirtualBox was working again I noticed that the Host key (which is the key used in different combinations to switch between the Host and the Guest OS) was not working. Instead it was flashing the Ubuntu desktop and pulsed some circles – like radar – from the cursor. At first I didn’t twig that it was simply the new mouse settings in the latest version of Ubuntu. By default it now seems the tickbox below in System->Preferences->Mouse for “Show position of pointer when the Control key is pressed” :

Mouse Settings in Ubuntu

Mouse Settings in Ubuntu

Hey presto – the host key works again! Hopefully this is helpful for anyone else confused by this one!

Also note the position of the sliders in the above screenshot for acceleration and sensitivity – I find these settings make the touchpad on my Vaio behave in a similar way to Windows (previously my mouse felt too sluggish).

I’m now actually using Windows less and less now at home (Evolution is a decent email client and of course Firefox offer pretty much the same browsing experience – apart from some differences with fonts, and OpenOffice allows for opening the odd Office attachment). The true acid test though is how much the wife moans as previously she’s never been happy without the familarity of Windows…! (But then it is still available in a couple of clicks).

I’m sure there will be more on my adventures of using Ubuntu on the desktop in due course – if I find time I’ll share anything I think others might find useful…



March 08, 2008
Filed Under (Linux, Open Source, Sony Stuff, Technology, Ubuntu) by Ollie Cronk on 08-03-2008

Desktop of Hardy HeronBit of a techy one here (so skip this if your not into Linux!) but sometimes these posts are useful to others!!!

Whilst trying to get my Sony memory stick slot (Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD) working on my Vaio under Ubuntu 7.10 (Gutsy) I came across this bug report where someone recommended trying the live CD of the latest release (Hardy Heron) to see if that fixed the issue.

Not sure is progress on the issue with the memory stick reader has been made – instead of:

[10321.605008] tifm_core: MemoryStick card detected in socket 0:0
[10321.611165] tifm_ms: Unknown symbol tifm_has_ms_pif

I now get:

tifm_core: MemoryStick card detected in socket 0:0

Which is possibly a bit of a backwards step!

However what I did discover is that the alpha (development) version of Hardy – the new 8.04 version of Ubuntu which is due for release next month – is pretty stable. So I have decided to take the plunge and did a dist upgrade (changing the /etc/apt/sources to reference hardy rather than gutsy and then running upgrade-manager -d). So far working well (hopefully not famous last words!!) writing this from it.

This thread (SONY VAIO MEMORY STICK: tifm_7xx1: sd card detected in socket 0)
and another on Ubuntu Forums discusses a similar issue / mounting SD cards and the latter suggests using

sudo mount /dev/tfa0 <mount point>

but this doesn’t work for me – if anyone knows how you look up what a device is likely to be listed as I’d be keen to know (need to do a bit of digging on this). I think I need to resolve the tifm_ms bit first.

I have been contributing the bug report (feels good to give something back after all the years of being a Linux user – now on the way to becoming a tester / bug reporter – who knows one day I might write some code for it!!)

Hardy comes with Firefox 3 beta 3 which seems really good also (hope I won’t be eating my words!) unfortunately Firebug and Google Brower sync (two plugins I can’t live without!) don’t seem to be available for it yet – so I am mostly using FF2 still.