Using Vista Offline Files with a Samba Share

So after tearing my hair out for the last week with Vista – almost to the point when I was going to put Windows XP back on – I have finally got Vista Offline files working with my Samba shares…

I like to move the My Documents folder on each of my machines from the C: drive to a network share that lives on my Linux file server – on my laptop I make that available offline – in case I am away from home etc. On Windows XP this was fine and worked pretty well. I recently upgraded to Vista and mapped the drive for my home directory – all good made it available offline (or “Always available offline” as Vista now calls it). It did its initial sync and all was good.

Next time I logon (and after making sure I am connected to the network) I go back to my network drive to make sure its working online – and nope it isn’t! I make sure I can ping the machine – thats okay and I can access the share online if I access the machine by its ip – \\192.168.1.4\share. Very weird and very frustrating!

Whilst searching for the solution I came across some useful info on making sure Samba is setup correctly for offline files (mainly to do with oplocks – see below for a useful link).

Anyway tonight I have a brain wave whilst looking at Vista’s user management stuff and reading some more stuff on the net. It turns out that Vista’s offline files works per user rather than per share and as a result is more reliant on usernames and passwords. My Samba share uses a different password to my vista login. So I made them the same – and hey presto it works!

So in summary if using offline files in Vista make sure your usernames and passwords match. I also think I’ve seen something under the user accounts section that lets you link in different user account details – but I haven’t tried that yet. Here is a screenshot.
Vista Network Password Screenshot

Vista Offline Files Samba Settings Link Broken as of June 08 ;-(

Published by Ollie Cronk

See the About page!

Join the Conversation

3 Comments

  1. Sorry to necro this… but I came across your posting and was wondering what changes exactly you made to your smb.conf file in terms of oplocks in order to get offline files working in Vista… Any help at all would be greatly appreciated. Thanks!

  2. Yeah, me too. About to chuck Linux out and install Windows Server because I just can’t get Offline Folders to work with Samba and it’s mission critical that I do so. The link in the article above doesn’t work any more.

Leave a comment

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.